不受支持的应用

您在商店中使用的某些应用可能因 Shopify API 更改而变得不受支持和停止工作。如果您商店中的应用使用不受支持的 API,您的 Shopify 后台中将显示通知。若要管理不受支持的应用,您可以联系应用开发者或在 Shopify 应用商店中查找新替代应用。详细了解如何管理不受支持的应用。

如果您已安装的应用变得与您的商店不兼容,那么您将在 Shopify 后台中收到应用通知,说明哪些商店设置与应用不兼容。

备注:如果您是应用开发者,请阅读 API 版本控制和最佳做法文档,详细了解如何使您的应用保持最新状态。

本页相关主题

  • 应用如何变得不受支持

  • 管理不受支持的应用

  • 安装不受支持的应用

应用如何变得不受支持

如果应用开发者未根据 Shopify API 的更改更新应用,则应用将变得不受支持。API(应用程序编程接口)是一个可供应用与 Shopify 进行通信的系统。您在商店中安装的应用使用 Shopify API 来获取和更新商店中的数据,并帮助您运营业务。

新的 Shopify API 版本每三个月发布一次。这些版本可能引入新功能或者更改和删除现有功能。每个版本的 Shopify API 都将持续工作一年,应用开发者必须在此期间内更新其应用才能使用更新的版本。

如果某个版本的 Shopify API 引入了会导致应用中断的更改,我们会通知应用开发者,并且他们有 9 个月的时间来更新应用。9 个月后,如果开发者未进行必要的更改,则该应用将变得不受支持,并且可能会停止工作。

管理不受支持的应用

不受支持的应用的更新由其开发者负责。可通过多种方式与应用开发者联系,具体取决于您使用的应用类型。

Shopify 会提早通知公共应用和自定义应用开发者有关重大更改的信息,以便他们有时间更新应用,避免应用变得不受支持。

如果您使用的应用变得不受支持,您可以联系开发者并请求他们更新应用。您还可以在 Shopify 应用商店中查找其他应用,以防您无法联系到开发者,或者需要替换正在使用的应用。

由于这些应用由第三方开发者维护,因此 Shopify 无法对这些应用执行任何更改或更新。

不受支持的自定义应用

自定义应用是由开发者或开发公司专门为您的 Shopify 商店开发的应用。Shopify 会向应用开发者的联系电子邮件发送有关即将发布的 API 更改可能导致您的应用中断的信息。为了确保开发者可收到这些警告,您可以在自定义应用的应用设置页面查看和更新与自定义应用关联的账户。

不受支持的专有应用

专有应用是由开发者或开发公司专门为您的 Shopify 商店开发的应用。Shopify 会向应用开发者的联系电子邮件发送有关即将发布的 API 更改可能导致您的应用中断的信息。为了确保开发者可收到这些警告,您可以在 Shopify 后台的专有应用页面上查看和更新开发者的联系电子邮件。

当您使用的专有应用变得不受支持时,您应联系该应用的开发者,请求他们更新该应用。您还应即时将收到的任何警告转发给应用开发者。

备注:如果您是专有应用开发者,请阅读专有应用版本控制扩展文档,详细了解如何使您的专有应用保持最新状态。

如果您没有开发者的联系邮箱,或者您不知道谁是您商店中安装的专有应用的开发者,请联系 Shopify 支持团队。如果您无法联系应用的原始开发者,则可聘请 Shopify 专家来帮助进行所需的更改。

如果专有应用变得不受支持,并且您未使用该应用或不打算更新该应用,则可以删除该应用以忽略 Shopify 后台中的警告。

不受支持的销售渠道

Shopify 会提早通知任何第三方销售渠道开发者有关重大更改的信息,以便他们有时间更新渠道,避免渠道变得不受支持。

如果您使用的销售渠道不受支持,请联系开发者并请求他们对其进行更新。如果您无法联系到开发者,则应卸载销售渠道。

由于这些销售渠道由第三方开发者维护,因此 Shopify 无法对这些应用执行任何更改或更新。

安装不受支持的应用

如果您尝试安装不受支持的应用,可能会看到警告,说明应用可能无法正常工作,或者您无法安装该应用。您可以联系开发者并请求他们更新应用,也可以在 Shopify 应用商店中查找其他应用。

Shopify商户官网原文详情:

Unsupported apps

Some of the apps that you use on your store might become unsupported and stop working because of changes to Shopify's APIs. When an app in your store uses an unsupported API, a notification is shown in your Shopify admin. You can manage an unsupported app by contacting the app's developers or by finding a new app in the Shopify App Store to replace it. Learn more about managing unsupported apps.

If an app that you've already installed becomes incompatible with your store, then you'll get an app notification in the Shopify admin that explains what store settings are incompatible with the app.

On this page

  • How apps become unsupported

  • Managing unsupported apps

  • Installing unsupported apps

How apps become unsupported

An app becomes unsupported if the app's developers don't keep it up to date with changes to Shopify's APIs. An API (application programming interface) is a system that allows apps to communicate with Shopify. The apps that you install on your store use Shopify APIs to get and update data on your store and help you run your business.

New versions of Shopify APIs are released every three months. These versions can introduce new features or change and remove existing features. Each version of a Shopify API continues to work for a year before app developers must update their apps to use a newer version.

If a certain version of a Shopify API introduces a change that breaks an app, then we notify the developer of that app, and they have 9 months to update it. After 9 months, if the developer doesn't make the required changes, then the app becomes unsupported and might stop working as expected.

Managing unsupported apps

The developer of an unsupported app is responsible for updating their app. There are different ways to reach out to the app developer that depends on the type of app you're using.

Shopify notifies the developers of public apps and custom apps about breaking changes early, so that they have time to update their apps before they become unsupported.

If an app that you're using becomes unsupported, then you can contact the developer and request that they update the app. You can also look for other apps on the Shopify App Store in case you can't reach the developer, or you need to replace the app that you're using.

Because these apps are maintained by third-party developers, Shopify can’t make any changes or update these apps for you.

Unsupported custom apps

A custom app is built exclusively for your Shopify store by a developer or development company. Shopify sends information about upcoming API changes that could break your app to the app developer's contact email. To make sure the developer is getting these warnings, you can view and update the account associated with the custom app on the custom app's App settings page.

Unsupported private apps

A private app is built exclusively for your Shopify store by a developer or development company. Shopify sends information about upcoming API changes that could break your app to the app developer's contact email. To make sure the developer is getting these warnings, you can view and update the developer's contact email on the Private apps page in the Shopify admin.

When a private app that you're using becomes unsupported, you should contact the developer of that app to request that they update it. You should also forward any warnings you get to the app developer as soon as you get them.

If you don’t have a contact email for your developer, or you don't know who developed a private app installed on your store, then contact Shopify Support. If you can't contact the original developer of the app, then you can hire a Shopify expert to help you make the required changes.

If a private app becomes unsupported, and you aren't using it or don’t plan to update it, then you can delete the app to dismiss the warning in your Shopify admin.

Unsupported sales channels

Shopify notifies the developers of any third-party sales channels about breaking changes early so that they have time to update them before they becom unsupported.

If a sales channel you're using becomes unsupported, then contact the developer and ask them to update it. If you can't reach the developer, then you should uninstall the sales channel.

Because these sales channels are maintained by third-party developers, Shopify can’t make any changes or update these apps for you.

Installing unsupported apps

If you try to install an app that's unsupported, you might see a warning that the app may not work properly, or that you won't be able to install it. You can contact the developer to ask them to update the app, or you can look for other apps on Shopify App Store.


文章内容来源:Shopify商户官方网站